路路发智能交易

 找回密码
 立即注册
查看: 1221|回复: 0

智能量化交易编程教程示例-Swing Index指标

[复制链接]

管理员

MT4软件工程师

Rank: 9Rank: 9Rank: 9

积分
6546
帖子
2772
主题
2762
QQ
发表于 2014-4-2 17:32:41 | 显示全部楼层 |阅读模式
智能量化交易编程教程示例-Swing Index指标
指标代码:
  1. LC:=REF(C,1);
  2. AA:=ABS(H-LC);
  3. BB:=ABS(L-LC);
  4. CC:=ABS(H-REF(L,1));
  5. DD:=ABS(LC-REF(O,1));
  6. R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
  7. X:=(C-LC+(C-O)/2+LC-REF(O,1));
  8. SI:16*X/R*MAX(AA,BB);
复制代码






外汇智能交易,成就财富梦想!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则


MT4编程培训|EA定制开发|QQ在线咨询|路路发智能交易 ( 沪ICP备13011711号-1 )

苏公网安备 32021102000151号

GMT+8, 2019-10-23 18:01 , Processed in 1.218750 second(s), 22 queries .

Powered by Discuz! X3.4

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表